What’s Vulnerable › Vulnerabilities
CVE-2026-50523: Microsoft PowerShell Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-14 · updated 2026-10-30
- Weakness: CWE-77
Description
Improper neutralization of special elements used in a command ('command injection') in Microsoft PowerShell allows an authorized attacker to execute code locally.
Affected products
- Microsoft Powershell: from 7.4 before 7.4.19.0; from 7.5 before 7.5.10.0; from 7.6 before 7.6.5 — fixed in 7.4.19.0, 7.5.10.0, 7.6.5
- Microsoft PowerShell 7.4: from 7.4.0 before 7.4.19.0 — fixed in 7.4.19.0
- Microsoft PowerShell 7.5: from 7.5.0 before 7.5.10.0 — fixed in 7.5.10.0
- Microsoft PowerShell 7.6: from 7.6.0 before 7.6.5 — fixed in 7.6.5
How to fix
Upgrade to a fixed version: Microsoft Powershell 7.4.19.0, 7.5.10.0, 7.6.5; Microsoft PowerShell 7.4 7.4.19.0; Microsoft PowerShell 7.5 7.5.10.0; Microsoft PowerShell 7.6 7.6.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-50523 or the next vulnerability affects your stack