What’s Vulnerable › Vulnerabilities
CVE-2026-50556: Angular: Missing `<noscript>` Raw-Text Serialization Escaping leads to Cross-Site Scripting (XSS) in Angular SSR
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-22 · updated 2026-07-15
- Weakness: CWE-79
Description
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.16, 20.3.24, and 19.2.25, a Cross-Site Scripting (XSS) vulnerability exists in @angular/platform-server's DOM emulation dependency (domino) when serializing the content of <noscript> elements. When rendering dynamic text content inside a <noscript> element via template bindings (such as {{ value }} or [textContent]), the template engine expects the browser to render the content safely. Under Server-Side Rendering (SSR), domino is configured with scripting enabled, meaning <noscript> is treated as a raw-text element. However, domino's serializer completely omitted <noscript> from the list of raw-text elements requiring closing-tag escaping during DOM serialization. As a result, any occurrence of </noscript> in the bound dynamic text was never escaped under any circumstances. The unescaped closing tag was serialized directly into the output HTML (e.g. <noscript></noscript><script>alert(1)</script></noscript>). When parsed by a browser, it closes the <noscript> block early, allowing the injected <script> block to execute in the user's browser context, causing same-origin Cross-Site Scripting (XSS). This vulnerability is fixed in 22.0.0-rc.2, 21.2.16, 20.3.24, and 19.2.25.
Affected products
- angular: through 18.2.14; from 19.0.0 before 19.2.25; from 20.0.0 before 20.3.24; from 21.0.0 before 21.2.16; 22.0.0-next0, 22.0.0-next1, 22.0.0-next10, 22.0.0-next11, 22.0.0-next12, 22.0.0-next2 (+9) — fixed in 19.2.25, 20.3.24, 21.2.16
How to fix
Upgrade to a fixed version: angular 19.2.25, 20.3.24, 21.2.16. Check the vendor advisory for mitigations.
References
- https://github.com/angular/angular/issues/68903
- https://github.com/angular/angular/security/advisories/GHSA-gxx4-3xcv-f8qx
- https://github.com/angular/domino/pull/29
- https://access.redhat.com/security/cve/CVE-2026-50556
- https://bugzilla.redhat.com/show_bug.cgi?id=2491459
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-50556.json
Get alerted when CVE-2026-50556 or the next vulnerability affects your stack