What’s Vulnerable › Vulnerabilities
CVE-2026-50632: Apache CXF: JNDI Injection Vulnerability in JMSConfigFactory
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-12 · updated 2026-10-26
- Weakness: CWE-20
Description
A further incomplete fix for a previous advisory CVE-2026-44417 (Untrusted JMS configuration can lead to RCE) for Apache CXF has been identified, which can allow code execution capabilities, if untrusted users are allowed to configure JMS for Apache CXF. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.
Affected products
- Apache Software Foundation Apache CXF: before 4.1.7; from 4.2.0 before 4.2.2 — fixed in 4.1.7, 4.2.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CXF 4.1.7, 4.2.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/740ghch5z5y675cn2kzgtyo5k37n6qcw
- https://access.redhat.com/errata/RHSA-2026:37390
- https://access.redhat.com/security/cve/CVE-2026-50632
- https://bugzilla.redhat.com/show_bug.cgi?id=2488304
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-50632.json
Get alerted when CVE-2026-50632 or the next vulnerability affects your stack