What’s Vulnerable › Vulnerabilities
CVE-2026-50633: Apache CXF: JNDI Injection vulnerability in DispatchMDBMessageListenerImpl
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-12 · updated 2026-10-26
- Weakness: CWE-20
Description
A JNDI Injection vulnerability has been discovered in Apache CXF's JCA integration module, which can allow for code execution, if an attacker is able to manipulate the JCA deployment descriptor (ra.xml) or runtime activation parameters. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.
Affected products
- Apache Software Foundation Apache CXF: before 4.1.7; from 4.2.0 before 4.2.2 — fixed in 4.1.7, 4.2.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CXF 4.1.7, 4.2.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/1czhgovkgzdkyp3t61wthn0foogh2grf
- http://www.openwall.com/lists/oss-security/2026/06/11/10
- https://access.redhat.com/errata/RHSA-2026:37390
- https://access.redhat.com/security/cve/CVE-2026-50633
- https://bugzilla.redhat.com/show_bug.cgi?id=2488307
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-50633.json
Get alerted when CVE-2026-50633 or the next vulnerability affects your stack