What’s Vulnerable › Vulnerabilities
CVE-2026-50638: Metrics::Any::Adapter::DogStatsd versions before 0.04 for Perl does not protect against metric injections
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-10 · updated 2026-10-26
- Weakness: CWE-93
Description
Metrics::Any::Adapter::DogStatsd versions before 0.04 for Perl does not protect against metric injections. The statsd protocol (and extensions such as dogstatsd) allow mutiple metrics, separated by newlines, to be sent per packet. Metrics::Any::Adapter::DogStatsd which extends Metrics::Any::Adapter::Statsd, which has a similar vulnerability. In addition, the _tags function does not check tags for newlines or statsd control characters. The tags can be used for metric injections.
Affected products
- PEVANS Metrics::Any::Adapter::Dogstatsd: before 0.04 — fixed in 0.04
How to fix
Upgrade to a fixed version: PEVANS Metrics::Any::Adapter::Dogstatsd 0.04. Check the vendor advisory for mitigations.
References
- https://metacpan.org/release/PEVANS/Metrics-Any-Adapter-Statsd-0.04/changes
- https://www.cve.org/CVERecord?id=CVE-2026-50637
- https://www.cve.org/CVERecord?id=CVE-2026-50639
- https://www.cve.org/CVERecord?id=CVE-2026-9270
Get alerted when CVE-2026-50638 or the next vulnerability affects your stack