What’s Vulnerable › Vulnerabilities
CVE-2026-50735
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-28 · updated 2026-10-23
- Weakness: CWE-125
Description
pglogical's apply worker does not sufficiently validate the length of certain fields in incoming replication protocol messages before copying them, resulting in an out-of-bounds read. A party acting as the publisher for a subscription, for example a non-PostgreSQL endpoint that speaks the pglogical replication protocol, can return crafted messages that cause the subscriber's apply worker to read beyond the bounds of an allocated buffer, disclosing adjacent process memory or crashing the worker. To exploit the issue an attacker must be able to direct a subscription at an endpoint they control. In default installations this requires privileges normally reserved for a superuser, so the issue is most relevant to managed deployments where the ability to create subscriptions has been delegated to non-superuser roles.
Affected products
- EnterpriseDB pglogical: from 2.0.0 before 2.4.8 — fixed in 2.4.8
How to fix
Upgrade to a fixed version: EnterpriseDB pglogical 2.4.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-50735 or the next vulnerability affects your stack