What’s Vulnerable › Vulnerabilities
CVE-2026-50737
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-28 · updated 2026-10-23
- Weakness: CWE-250
Description
When applying replicated changes for a row that is missing one or more columns, pglogical evaluates the affected table's default expressions on the subscriber. Because the apply worker runs at a privilege level equivalent to a PostgreSQL superuser in default installations, any function invoked by such a default expression also runs at that privilege. A party acting as the publisher can use this path to cause functions to be executed on the subscriber as superuser, escalating from a role permitted to use pglogical to full superuser. This is a second, independent path to the same superuser escalation tracked under CVE-2026-50736 (the pglogical queue issue). To exploit the issue an attacker must be able to direct a subscription at an endpoint they control. In default installations this requires privileges normally reserved for a superuser, so the issue is most relevant to managed deployments where the ability to create subscriptions has been delegated to non-superuser roles.
Affected products
- EnterpriseDB pglogical: from 2.0.0 before 2.4.8 — fixed in 2.4.8
How to fix
Upgrade to a fixed version: EnterpriseDB pglogical 2.4.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-50737 or the next vulnerability affects your stack