What’s Vulnerable › Vulnerabilities
CVE-2026-5079: multer vulnerable to Denial of Service via deeply nested field names
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-15 · updated 2026-06-17
- Weakness: CWE-400
Description
Impact: multer versions 1.0.0 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service via deeply nested field names in multipart form data. The append-field dependency parses bracket notation in field names with no limit on nesting depth, allowing an attacker to force allocation of deeply nested object structures that consume CPU and memory. A single HTTP request with a crafted multipart body is sufficient to exploit this. Patches: Users should upgrade to multer 2.2.0 (2.x line) or 3.0.0-alpha.2 (3.x prerelease) and configure the new limits.fieldNestingDepth option to the minimum depth their application requires. Workarounds: Set limits.fields to a reasonable value to reduce the number of fields an attacker can send per request. This does not fully mitigate the issue but limits the impact.
Affected products
- multer: from 1.0.0 before 2.2.0; 3.0.0-alpha1 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: multer 2.2.0. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/expressjs/multer/security/advisories/GHSA-72gw-mp4g-v24j
Get alerted when CVE-2026-5079 or the next vulnerability affects your stack