What’s Vulnerable › Vulnerabilities

CVE-2026-5139: GitLab Plugin Allows Non-Admin Users to Modify Default Instance Configuration

Description

Mattermost versions 11.7.x <= 11.7.0, 11.6.x <= 11.6.2, 11.5.x <= 11.5.5, 10.11.x <= 10.11.17 fail to enforce administrator authorization on the {{setDefaultInstance}} call within the {{/gitlab connect}} command handler, which allows any authenticated user to overwrite the global default GitLab instance configuration via the {{/gitlab connect <instance-name>}} slash command.. Mattermost Advisory ID: MMSA-2026-00644

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.18, 11.5.6, 11.6.3, 11.7.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-5139 or the next vulnerability affects your stack