What’s Vulnerable › Vulnerabilities
CVE-2026-5160: Cross-site Scripting (XSS) in github.com/yuin/goldmark
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Versions of the package github.com/yuin/goldmark/renderer/html before 1.7.17 are vulnerable to Cross-site Scripting (XSS) due to improper ordering of URL validation and normalization. The renderer validates link destinations using a prefix-based check (IsDangerousURL) before resolving HTML entities. This allows an attacker to bypass protocol filtering by encoding dangerous schemes using HTML5 named character references. For example, a payload such as javascript:alert(1) is not recognized as dangerous during validation, leading to arbitrary script execution in the context of applications that render the URL.
Affected products
- github.com/yuin/goldmark/renderer/html: before 1.7.17 — fixed in 1.7.17
- Go Github.Com/Yuin/Goldmark: before 1.7.17 — fixed in 1.7.17
How to fix
Upgrade to a fixed version: github.com/yuin/goldmark/renderer/html 1.7.17; Go Github.Com/Yuin/Goldmark 1.7.17. Check the vendor advisory for mitigations.
References
- https://github.com/yuin/goldmark/commit/cb46bbc4eca29d55aa9721e04ad207c23ccc44f9
- https://security.snyk.io/vuln/SNYK-GOLANG-GITHUBCOMYUINGOLDMARKRENDERERHTML-15838406
Get alerted when CVE-2026-5160 or the next vulnerability affects your stack