What’s Vulnerable › Vulnerabilities
CVE-2026-5173: Exposed Dangerous Method or Function in GitLab
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-08 · updated 2026-07-24
- Weakness: CWE-749
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 16.9.6 before 18.8.9, 18.9 before 18.9.5, and 18.10 before 18.10.3 that could have allowed an authenticated user to invoke unintended server-side methods through websocket connections due to improper access control.
Affected products
- GitLab: from 16.9.6 before 18.8.9; from 18.9.0 before 18.9.5; from 18.10.0 before 18.10.3 — fixed in 18.10.3, 18.8.9, 18.9.5
How to fix
Upgrade to a fixed version: GitLab 18.10.3, 18.8.9, 18.9.5. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2026/04/08/patch-release-gitlab-18-10-3-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/588959
Get alerted when CVE-2026-5173 or the next vulnerability affects your stack