What’s Vulnerable › Vulnerabilities
CVE-2026-5194: wolfSSL ECDSA Certificate Verification
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-09 · updated 2026-06-17
- Weakness: CWE-295
Description
Missing hash/digest size and OID checks allow digests smaller than allowed when verifying ECDSA certificates, or smaller than is appropriate for the relevant key type, to be accepted by signature verification functions. This could lead to reduced security of ECDSA certificate-based authentication if the public CA key used is also known. This affects ECDSA/ECC verification when EdDSA or ML-DSA is also enabled.
Affected products
- wolfSSL: from 3.12.0 before 5.9.1 — fixed in 5.9.1
How to fix
Upgrade to a fixed version: wolfSSL 5.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/wolfSSL/wolfssl/pull/10131
- https://www.anthropic.com/research/glasswing-initial-update
Get alerted when CVE-2026-5194 or the next vulnerability affects your stack