What’s Vulnerable › Vulnerabilities
CVE-2026-5262: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-22 · updated 2026-06-17
- Weakness: CWE-79
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 16.1.0 before 18.9.6, 18.10 before 18.10.4, and 18.11 before 18.11.1 that under certain conditions could have allowed an unauthenticated user to access tokens in the Storybook development environment due to improper input validation.
Affected products
- GitLab: from 16.1.0 before 18.9.6; from 18.10.0 before 18.10.4; 18.11.0 — fixed in 18.10.4, 18.9.6
How to fix
Upgrade to a fixed version: GitLab 18.10.4, 18.9.6. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2026/04/22/patch-release-gitlab-18-11-1-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/595332
- https://hackerone.com/reports/3574642
Get alerted when CVE-2026-5262 or the next vulnerability affects your stack