What’s Vulnerable › Vulnerabilities
CVE-2026-52688: RRSIGs with too few labels can lead to bypass of DNSSEC wildcard validation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-23 · updated 2026-10-24
- Weakness: CWE-295
Description
RRSIGs with too few labels can lead to bypass of DNSSEC wildcard validation
Affected products
- PowerDNS Recursor: from 5.2.0 before 5.2.12; from 5.3.0 before 5.3.9; from 5.4.0 before 5.4.4 — fixed in 5.2.12, 5.3.9, 5.4.4
How to fix
Upgrade to a fixed version: PowerDNS Recursor 5.2.12, 5.3.9, 5.4.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-52688 or the next vulnerability affects your stack