What’s Vulnerable › Vulnerabilities
CVE-2026-52724: kuma-dp connects to control plane without verifying TLS certificate when no CA is configured
- Severity: medium (CVSS 5.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-30
- Weakness: CWE-295
Description
Kuma is a modern Envoy-based service mesh that can run on every cloud across both Kubernetes and VMs. Prior to 2.7.26, 2.9.16, 2.11.14, 2.12.11, and 2.13.7, Universal mode kuma-dp connections to an HTTPS control plane disable TLS peer verification when --ca-cert-file is not supplied and KUMA_CONTROL_PLANE_CA_CERT is unset. The dataplane authentication token is sent over the unverified connection, allowing an on-path attacker to intercept the token, impersonate the control plane, inject a forged bootstrap configuration, and take over the proxy. Standard Kubernetes installations created by kumactl install control-plane or the official Helm chart are unaffected because the mutating admission webhook injects KUMA_CONTROL_PLANE_CA_CERT into each sidecar. This issue is fixed in versions 2.7.26, 2.9.16, 2.11.14, 2.12.11, and 2.13.7.
Affected products
- kumahq kuma: before 2.7.26; from 2.8.0, < 2.9.16; from 2.10.0, < 2.11.14; from 2.12.0, < 2.12.11; from 2.13.0, < 2.13.7
References
- https://github.com/kumahq/kuma/commit/2d0fb382924598f8746bc85c896f50384675940f
- https://github.com/kumahq/kuma/commit/85716397ffa404234bf365da0967eca0b0fa1870
- https://github.com/kumahq/kuma/commit/a256af4869ae7e0ebbc2a14dc231e04ac8df1ba3
- https://github.com/kumahq/kuma/commit/bb56ae628753aaec1f7846a514ab4edc35c0b569
- https://github.com/kumahq/kuma/commit/d4ae0c0151596be991897651f20c5cdf32de1980
- https://github.com/kumahq/kuma/commit/eb81494c2c7a5536e55c19cdde51b02a03b51e11
- https://github.com/kumahq/kuma/pull/16777
- https://github.com/kumahq/kuma/security/advisories/GHSA-wvmp-6r4v-j6cv
Get alerted when CVE-2026-52724 or the next vulnerability affects your stack