What’s Vulnerable › Vulnerabilities
CVE-2026-52760: Apache ActiveMQ, Apache ActiveMQ Web Console: Stored XSS via Unescaped values in ActiveMQ Web Console
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-30 · updated 2026-07-02
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache ActiveMQ, Apache ActiveMQ Web Console. The browse page in the web console renders a message Id directly without sanitization. This allows an authenticated producer to send a message with a JMS message ID that has been crafted to contain HTML/JavaScript such that when an administrator browses the queue in the Web Console, the payload executes in their browser. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Web Console: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Affected products
- Apache ActiveMQ: before 5.19.8; from 6.0.0 before 6.2.7 — fixed in 5.19.8, 6.2.7
- Apache Activemq Web: before 5.19.8; from 6.0.0 before 6.2.7 — fixed in 5.19.8, 6.2.7
How to fix
Upgrade to a fixed version: Apache ActiveMQ 5.19.8, 6.2.7; Apache Activemq Web 5.19.8, 6.2.7. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/d3mhyo2116nomz2lwxppyy4pclvdxq3n
- http://www.openwall.com/lists/oss-security/2026/06/29/12
Get alerted when CVE-2026-52760 or the next vulnerability affects your stack