What’s Vulnerable › Vulnerabilities
CVE-2026-52797: Gogs: Overwriting critical files results in a denial of service
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-24 · updated 2026-06-25
- Weakness: CWE-22
Description
Gogs is an open source self-hosted Git service. Prior to 0.14.0, as an authorized user, an intruder can dictate the value which is passed to the git diff command which, together with bypassing the filtering of the passed value, allows the user to bypass the target directory and write the result of the comparison to any arbitrary path. This vulnerability is fixed in 0.14.0.
Affected products
- gogs: before 0.14.0
References
- https://github.com/gogs/gogs/security/advisories/GHSA-pm6v-2h4w-4rp2
- https://github.com/gogs/gogs/security/advisories/GHSA-pm6v-2h4w-4rp2
Get alerted when CVE-2026-52797 or the next vulnerability affects your stack