What’s Vulnerable › Vulnerabilities
CVE-2026-52808: Gogs: Write-level collaborators can mutate admin-only repository settings via API
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-24 · updated 2026-06-25
- Weakness: CWE-269
Description
Gogs is an open source self-hosted Git service. Prior to 0.14.3, three API endpoints — PATCH /api/v1/repos/:owner/:repo/issue-tracker, PATCH /api/v1/repos/:owner/:repo/wiki, and POST /api/v1/repos/:owner/:repo/mirror-sync — are gated by reqRepoWriter() rather than reqRepoAdmin(). The equivalent operations in the web UI sit behind reqRepoAdmin, which requires AccessMode >= AccessModeAdmin. A write-level collaborator (who has AccessMode == AccessModeWrite < AccessModeAdmin) can therefore call these API endpoints directly to disable the native issue tracker or wiki, inject attacker-controlled external tracker/wiki URLs that redirect all repository visitors, or trigger mirror sync — none of which they are authorized to do. This vulnerability is fixed in 0.14.3.
Affected products
- gogs: before 0.14.3
References
- https://github.com/gogs/gogs/commit/6283462119bd8894f1599d70339b5e823f99954a
- https://github.com/gogs/gogs/pull/8327
- https://github.com/gogs/gogs/releases/tag/v0.14.3
- https://github.com/gogs/gogs/security/advisories/GHSA-268j-37xf-pp52
- https://github.com/gogs/gogs/security/advisories/GHSA-268j-37xf-pp52
Get alerted when CVE-2026-52808 or the next vulnerability affects your stack