What’s Vulnerable › Vulnerabilities
CVE-2026-52845: Caddy: FastCGI header normalization bypass in `forward_auth copy_headers`
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-23 · updated 2026-10-25
- Weakness: CWE-287
Description
Caddy is an extensible server platform that uses TLS by default. Prior to 2.11.4, forward_auth copy_headers deletes the exact client-supplied identity header before copying the trusted value from the auth gateway. But when the request later goes through php_fastcgi, Caddy normalizes HTTP headers into CGI variables by replacing - with _. This lets a client send an underscore alias that survives the forward_auth delete step but becomes the same PHP/FastCGI variable. Result: a remote client can inject or sometimes override identity/group headers trusted by PHP/FastCGI applications behind Caddy. This vulnerability is fixed in 2.11.4.
Affected products
- caddyserver caddy: before 2.11.4 — fixed in 2.11.4
How to fix
Upgrade to a fixed version: caddyserver caddy 2.11.4. Check the vendor advisory for mitigations.
References
- https://github.com/caddyserver/caddy/security/advisories/GHSA-f59h-q822-g45g
- https://access.redhat.com/security/cve/CVE-2026-52845
- https://bugzilla.redhat.com/show_bug.cgi?id=2491907
- https://github.com/caddyserver/caddy/security/advisories/GHSA-f59h-q822-g45g
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-52845.json
Get alerted when CVE-2026-52845 or the next vulnerability affects your stack