What’s Vulnerable › Vulnerabilities
CVE-2026-52858: Vim: Arbitrary Code Execution via Python Omni-Completion
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-11 · updated 2026-06-17
- Weakness: CWE-94
Description
Vim is an open source, command line text editor. Prior to version 9.2.0561, the Python omni-completion script in python3complete.vim for Vim with the +python3 interpreter enabled (and the legacy pythoncomplete.vim for builds with the +python interpreter) executes the import and from statements found in the current buffer through Python's import machinery. Because the buffer's working directory is on sys.path, opening a hostile .py file with a sibling Python package and invoking omni-completion runs that package's top-level code as the editing user. This issue has been patched in version 9.2.0561.
Affected products
- vim/vim: before 9.2.0561 — fixed in 9.2.0561
How to fix
Upgrade to a fixed version: vim/vim 9.2.0561. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/4b850457e12e1a678dd209f2868154f7553cbf8d
- https://github.com/vim/vim/releases/tag/v9.2.0561
- https://github.com/vim/vim/security/advisories/GHSA-52mc-rq6p-rc7c
Get alerted when CVE-2026-52858 or the next vulnerability affects your stack