What’s Vulnerable › Vulnerabilities
CVE-2026-52865: NGINX Ingress Controller vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-10-24
- Weakness: CWE-476
Description
When NGINX Ingress Controller processes Ingress or TransportServer resources, an authenticated, remote attacker with permission to create or modify Ingress or TransportServer resources can cause the NGINX Ingress Controller process to terminate. Impact: The NGINX Ingress Controller control plane process terminates and enters a persistent crash loop while the malformed Ingress or TransportServer resource remains in the cluster. This vulnerability allows a remote, authenticated attacker with at least Ingress or TransportServer resource write access to cause a denial-of-service (DoS) on the NGINX Ingress Controller system. There is no data plane exposure; this is a control plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Ingress Controller: from 3.5.0 through 3.7.2; from 4.0.0 through 4.0.1; from 5.0.0 before 5.5.2 — fixed in 5.5.2
How to fix
Upgrade to a fixed version: F5 NGINX Ingress Controller 5.5.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-52865 or the next vulnerability affects your stack