What’s Vulnerable › Vulnerabilities
CVE-2026-52904: drm/nouveau: fix nvkm_device leak on aperture removal failure
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-09 · updated 2026-07-23
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: drm/nouveau: fix nvkm_device leak on aperture removal failure When aperture_remove_conflicting_pci_devices() fails during probe, the error path returns directly without unwinding the nvkm_device that was just allocated by nvkm_device_pci_new(). This leaks both the device wrapper and the pci_enable_device() reference taken inside it. Jump to the existing fail_nvkm label so nvkm_device_del() runs and balances both. The leak was introduced when the intermediate nvkm_device_del() between detection and aperture removal was dropped in favor of creating the pci device once.
Affected products
- Linux kernel: from 6.12 before 6.12.86; from 6.13 before 6.18.27; from 6.19 before 7.0.4 — fixed in 6.12.86, 6.18.27, 7.0.4
How to fix
Upgrade to a fixed version: Linux kernel 6.12.86, 6.18.27, 7.0.4. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4404d7d2dda4f3cc84a8fb6ac5417a2afc3b22d6
- https://git.kernel.org/stable/c/5edd564ccb002ffc830e7818c1c4a992db774678
- https://git.kernel.org/stable/c/6597ff1d8de3f583be169587efeafd8af134e138
- https://git.kernel.org/stable/c/843c0247cf21364e33bb5a8ffc9af57107d04d05
Get alerted when CVE-2026-52904 or the next vulnerability affects your stack