What’s Vulnerable › Vulnerabilities
CVE-2026-52931: batman-adv: tp_meter: avoid use of uninit sender vars
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-24 · updated 2026-10-19
- Weakness: CWE-457
Description
In the Linux kernel, the following vulnerability has been resolved: batman-adv: tp_meter: avoid use of uninit sender vars batadv_tp_recv_ack() and batadv_tp_stop() are only valid for tp_vars in the BATADV_TP_SENDER role. When called with a BATADV_TP_RECEIVER role, it proceeds to read sender-only members that were never initialized, leading to undefined behavior. This can be triggered when a node that is currently acting as a receiver in an ongoing tp_meter session receives a malicious ACK packet. Guard against this by checking tp_vars->role immediately after the lookup and bailing out if it is not BATADV_TP_SENDER, before any of those members are accessed.
Affected products
- Linux kernel: from 4.8 before 5.10.258; from 5.11 before 5.15.209; from 5.16 before 6.1.175; from 6.2 before 6.6.142; from 6.7 before 6.12.92; from 6.13 before 6.18.34 — fixed in 5.10.258, 5.15.209, 6.1.175, 6.12.92, 6.18.34, 6.6.142
How to fix
Upgrade to a fixed version: Linux kernel 5.10.258, 5.15.209, 6.1.175, 6.12.92. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0e388af04b3958b178a1b979527f93eb46ea1fee
- https://git.kernel.org/stable/c/1a21c055f66e78973712a4a1be2a554f1ee2e4f4
- https://git.kernel.org/stable/c/53f931e0146ae5bdab4cba302646827d06b3794b
- https://git.kernel.org/stable/c/6c65cf23d4c6170fcf5714c32aa64689718cb142
- https://git.kernel.org/stable/c/85397e48afe6be83ffca5ad3f4792296bfc81d3d
- https://git.kernel.org/stable/c/9884c9c02d3c90e9215db3c5128f59045d20ae91
- https://git.kernel.org/stable/c/dc2ae5fbd2dadc26735092f140b246841d969a11
- https://git.kernel.org/stable/c/ecdaa3e4d91040206afe21bc8a0d1198a0971ff3
Get alerted when CVE-2026-52931 or the next vulnerability affects your stack