What’s Vulnerable › Vulnerabilities
CVE-2026-52963: ALSA: usb-audio: Bound MIDI endpoint descriptor scans
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-24 · updated 2026-07-14
Description
In the Linux kernel, the following vulnerability has been resolved: ALSA: usb-audio: Bound MIDI endpoint descriptor scans snd_usbmidi_get_ms_info() validates the internal MIDIStreaming endpoint descriptor size before using baAssocJackID[], but the descriptor walker can still return a class-specific endpoint descriptor whose bLength exceeds the remaining bytes in the endpoint-extra scan. That leaves later flexible-array reads bounded by bLength, but not by the remaining bytes in the endpoint-extra scan. Stop walking when bLength is zero or extends past the remaining endpoint-extra scan.
Affected products
- Linux kernel: from 4.4.238 before 4.5; from 4.9.238 before 4.10; from 4.14.200 before 4.15; from 4.19.149 before 4.20; from 5.4.69 before 5.5; from 5.7 before 5.10.258 — fixed in 4.10, 4.15, 4.20, 4.5, 5.10.258, 5.15.209
How to fix
Upgrade to a fixed version: Linux kernel 4.10, 4.15, 4.20, 4.5. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/09141583bd97f4bbd7358e29fd138fe798467cdb
- https://git.kernel.org/stable/c/3d3b2b01a3e73828e201ece96f863e7a3e0cdc6e
- https://git.kernel.org/stable/c/728ab0c72e49ca27185067984cd565425eb69b2e
- https://git.kernel.org/stable/c/a0226560540c16717efcceaf15c862cf115b01d3
- https://git.kernel.org/stable/c/c59159ce10e75b568cd0d4b29efcb0fb0ddecc94
- https://git.kernel.org/stable/c/c65b137d351e21cbc5630e73ef0eb1e1d75f5b20
- https://git.kernel.org/stable/c/d6854daa67be623860f4e1873fd3d3c275aba4ed
- https://git.kernel.org/stable/c/e2f1260a056eb3215c13c48c5378f3e4112dc3af
Get alerted when CVE-2026-52963 or the next vulnerability affects your stack