What’s Vulnerable › Vulnerabilities
CVE-2026-53021: scsi: target: core: Fix integer overflow in UNMAP bounds check
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-24 · updated 2026-07-15
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: target: core: Fix integer overflow in UNMAP bounds check sbc_execute_unmap() checks LBA + range does not exceed the device capacity, but does not guard against LBA + range wrapping around on 64-bit overflow. Add an overflow check matching the pattern already used for WRITE_SAME in the same file.
Affected products
- Linux kernel: from 3.10 before 5.10.258; from 5.11 before 5.15.209; from 5.16 before 6.1.175; from 6.2 before 6.6.141; from 6.7 before 6.12.91; from 6.13 before 6.18.33 — fixed in 5.10.258, 5.15.209, 6.1.175, 6.12.91, 6.18.33, 6.6.141
How to fix
Upgrade to a fixed version: Linux kernel 5.10.258, 5.15.209, 6.1.175, 6.12.91. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/02115986d027ade793e7f6be87e91d6a796d0aa3
- https://git.kernel.org/stable/c/2bf2d65f76697820dbc4227d13866293576dd90a
- https://git.kernel.org/stable/c/2e1ed9a7b6ea5bfefb5d80a02b1c71c7dee1f0dd
- https://git.kernel.org/stable/c/3facdecc3fcf115cc4f9b3d8f118d6705e2456a8
- https://git.kernel.org/stable/c/51075df70c46e60a9773f2dcd28299e40dac36fb
- https://git.kernel.org/stable/c/5efc3ef4758f8d98c257419fa21daca3227de61a
- https://git.kernel.org/stable/c/c08ab702c4699c6efb9d60bdb15b73e7a627ee7e
- https://git.kernel.org/stable/c/d7aef29573c7c5cdb2dfad939253287a6329c2a4
Get alerted when CVE-2026-53021 or the next vulnerability affects your stack