What’s Vulnerable › Vulnerabilities
CVE-2026-53022: platform/x86: dell-wmi-sysman: bound enumeration string aggregation
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-24 · updated 2026-07-15
Description
In the Linux kernel, the following vulnerability has been resolved: platform/x86: dell-wmi-sysman: bound enumeration string aggregation populate_enum_data() aggregates firmware-provided value-modifier and possible-value strings into fixed 512-byte struct members. The current code bounds each individual source string but then appends every string and separator with raw strcat() and no remaining-space check. Switch the aggregation loops to a bounded append helper and reject enumeration packages whose combined strings do not fit in the destination buffers. [ij: add include]
Affected products
- Linux kernel: from 5.11 before 5.15.209; from 5.16 before 6.1.175; from 6.2 before 6.6.141; from 6.7 before 6.12.91; from 6.13 before 6.18.33; from 6.19 before 7.0.10 — fixed in 5.15.209, 6.1.175, 6.12.91, 6.18.33, 6.6.141, 7.0.10
How to fix
Upgrade to a fixed version: Linux kernel 5.15.209, 6.1.175, 6.12.91, 6.18.33. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3c34471c26abc52a37f5ad90949e2e4b8027eb14
- https://git.kernel.org/stable/c/5a04f9a36930792f6d64e28d43609e158d09b665
- https://git.kernel.org/stable/c/75c738d4f27fa18a2a033de153bd40302bde6a66
- https://git.kernel.org/stable/c/7b3dc1f764bf24eb99474a5de8173b0b43a8b071
- https://git.kernel.org/stable/c/90b118d264845f7aaf539ac49f7c75f1f29590e2
- https://git.kernel.org/stable/c/ba0843c1955864401295f7ba3b420afe19f2266d
- https://git.kernel.org/stable/c/c5683ca4949a514fbe656c6d0d08c4c126e21db9
Get alerted when CVE-2026-53022 or the next vulnerability affects your stack