What’s Vulnerable › Vulnerabilities
CVE-2026-53115: bus: fsl-mc: use generic driver_override infrastructure
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-24 · updated 2026-10-21
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: bus: fsl-mc: use generic driver_override infrastructure When a driver is probed through __driver_attach(), the bus' match() callback is called without the device lock held, thus accessing the driver_override field without a lock, which can cause a UAF. Fix this by using the driver-core driver_override infrastructure taking care of proper locking internally. Note that calling match() from __driver_attach() without the device lock held is intentional. [1]
Affected products
- Linux kernel: from 5.10 before 6.12.91; from 6.13 before 6.18.33; from 6.19 before 7.0.10 — fixed in 6.12.91, 6.18.33, 7.0.10
How to fix
Upgrade to a fixed version: Linux kernel 6.12.91, 6.18.33, 7.0.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4911b836f35c034c36f102db4ecbe339b38e7d1d
- https://git.kernel.org/stable/c/60bfb563a399c4597dc80588a1109758a8908b97
- https://git.kernel.org/stable/c/6c8dfb0362732bf1e4829867a2a5239fedc592d0
- https://git.kernel.org/stable/c/8139ce66b52a4a5638bfb445b037c07d4abeb08e
- https://git.kernel.org/stable/c/dbba371b19129abe9649553ab912e6bccf6c1a5b
Get alerted when CVE-2026-53115 or the next vulnerability affects your stack