What’s Vulnerable › Vulnerabilities
CVE-2026-53119: platform/wmi: use generic driver_override infrastructure
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-24 · updated 2026-07-23
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: platform/wmi: use generic driver_override infrastructure When a driver is probed through __driver_attach(), the bus' match() callback is called without the device lock held, thus accessing the driver_override field without a lock, which can cause a UAF. Fix this by using the driver-core driver_override infrastructure taking care of proper locking internally. Note that calling match() from __driver_attach() without the device lock held is intentional. [1]
Affected products
- Linux kernel: from 6.11 before 6.12.91; from 6.13 before 6.18.33; from 6.19 before 7.0.10 — fixed in 6.12.91, 6.18.33, 7.0.10
How to fix
Upgrade to a fixed version: Linux kernel 6.12.91, 6.18.33, 7.0.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/13d201bd840d2e2a645ef899f81342cd27ced346
- https://git.kernel.org/stable/c/2c5507010fc3b8e2bd596c63c88f6ad39a69b1c4
- https://git.kernel.org/stable/c/4dc755d86deed88789540d960e421124bad4c568
- https://git.kernel.org/stable/c/8a700b1fc94df4d847a04f14ebc7f8532592b367
Get alerted when CVE-2026-53119 or the next vulnerability affects your stack