What’s Vulnerable › Vulnerabilities
CVE-2026-53120: PCI: use generic driver_override infrastructure
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-24 · updated 2026-10-21
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: PCI: use generic driver_override infrastructure When a driver is probed through __driver_attach(), the bus' match() callback is called without the device lock held, thus accessing the driver_override field without a lock, which can cause a UAF. Fix this by using the driver-core driver_override infrastructure taking care of proper locking internally. Note that calling match() from __driver_attach() without the device lock held is intentional. [1]
Affected products
- Linux kernel: from 3.16 before 6.12.91; from 6.13 before 6.18.33; from 6.19 before 7.0.10 — fixed in 6.12.91, 6.18.33, 7.0.10
How to fix
Upgrade to a fixed version: Linux kernel 6.12.91, 6.18.33, 7.0.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/10a4206a24013be4d558d476010cbf2eb4c9fa64
- https://git.kernel.org/stable/c/58a42be0d70307d765594fc581f5f5e5ef059712
- https://git.kernel.org/stable/c/c5b2c5755495507e14f310c2653c85de0a309b1f
- https://git.kernel.org/stable/c/dfe950d9464cad609f3b118c6203e2708055bc61
- https://git.kernel.org/stable/c/fdfa287956d00b936e0ac409b21e4f90501ad109
Get alerted when CVE-2026-53120 or the next vulnerability affects your stack