What’s Vulnerable › Vulnerabilities
CVE-2026-53168: fuse: reject fuse_notify() pagecache ops on directories
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: fuse: reject fuse_notify() pagecache ops on directories The operations FUSE_NOTIFY_STORE and FUSE_NOTIFY_RETRIEVE allow the FUSE daemon to actively write/read pagecache contents. For directories with FOPEN_CACHE_DIR, the pagecache is used as kernel-internal cache storage, and userspace is not supposed to have direct access to this cache - in particular, fuse_parse_cache() will hit WARN_ON() if the cache contains bogus data. Reject FUSE_NOTIFY_STORE and FUSE_NOTIFY_RETRIEVE on anything other than regular files with -EINVAL.
Affected products
- Linux kernel: from 4.20 before 5.10.259; from 5.11 before 5.15.210; from 5.16 before 6.1.176; from 6.2 before 6.6.143; from 6.7 before 6.12.94; from 6.13 before 6.18.36 — fixed in 5.10.259, 5.15.210, 6.1.176, 6.12.94, 6.18.36, 6.6.143
How to fix
Upgrade to a fixed version: Linux kernel 5.10.259, 5.15.210, 6.1.176, 6.12.94. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/12df4cfa738aefff21756728e91056d7defb0fe6
- https://git.kernel.org/stable/c/15487f98863dc7156ed43c5be26d478beb82ba35
- https://git.kernel.org/stable/c/99c317d7f8b7bbf3de16d20a01f363e390114cea
- https://git.kernel.org/stable/c/9c954499d43aefac01c5dfb57a82b13d2dcf4b94
- https://git.kernel.org/stable/c/9dbf1b2fadfc6c40805631d8a8276d1639fc9ab6
- https://git.kernel.org/stable/c/bd23fa0c16c5c86e5b7713224ffbb87d9db81cca
- https://git.kernel.org/stable/c/dd92773d4d9cea010474eb08a5133c14ff6ab53a
- https://git.kernel.org/stable/c/e692f0cb86204dcdb9dddc0b355407eda6394a67
- https://cert-portal.siemens.com/productcert/html/ssa-784472.html
Get alerted when CVE-2026-53168 or the next vulnerability affects your stack