What’s Vulnerable › Vulnerabilities
CVE-2026-53178: staging: rtl8723bs: rtw_mlme: add bounds checks before ie_length subtraction
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-10-30
- Weakness: CWE-191
Description
In the Linux kernel, the following vulnerability has been resolved: staging: rtl8723bs: rtw_mlme: add bounds checks before ie_length subtraction Add guards to ensure ie_length is large enough before subtracting fixed IE offsets to prevent unsigned integer underflow.
Affected products
- Linux kernel: from 5.15 before 7.0.13; 7.1-rc1, 7.1-rc2, 7.1-rc3, 7.1-rc4, 7.1-rc5, 7.1-rc6 (+1) — fixed in 7.0.13
- Linux: from 5.10.273 before 5.11 — fixed in 5.11
How to fix
Upgrade to a fixed version: Linux kernel 7.0.13; Linux 5.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/18143799ad51a32b1351e4e1591b6285a0a9d7dd
- https://git.kernel.org/stable/c/542d65a6dbd9733baab96313c9fe76a76e93f484
- https://git.kernel.org/stable/c/637e0ea73f690028796ee2fc72a2ac4ec32968c6
- https://git.kernel.org/stable/c/8863ac3a4fedf86b0ef5b8ecc37fbaa52f2a8160
- https://git.kernel.org/stable/c/88e994c57a79f62d5338231d8d37ee8dd98baffe
Get alerted when CVE-2026-53178 or the next vulnerability affects your stack