What’s Vulnerable › Vulnerabilities
CVE-2026-53179: staging: rtl8723bs: fix buffer over-read in rtw_update_protection
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-10-21
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: staging: rtl8723bs: fix buffer over-read in rtw_update_protection rtw_update_protection() is called with a pointer offset into the ies buffer but the full ie_length is passed, causing a potential buffer over-read.
Affected products
- Linux kernel: from 5.15 before 6.18.36; from 6.19 before 7.0.13; 7.1-rc1, 7.1-rc2, 7.1-rc3, 7.1-rc4, 7.1-rc5, 7.1-rc6 (+1) — fixed in 6.18.36, 7.0.13
How to fix
Upgrade to a fixed version: Linux kernel 6.18.36, 7.0.13. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/303f65af819f6d5aa302e82bce72b57a8575faea
- https://git.kernel.org/stable/c/514ab98364595007d4557ecc85d7e5f012c504d3
- https://git.kernel.org/stable/c/735dabdf21561a24d8bcae456c9c32f7f961a029
- https://git.kernel.org/stable/c/c35ce55b12bb8fcd365daeb516e9782048119b36
- https://git.kernel.org/stable/c/d95edbbf7830d77ad68d437c384055eac8cd9892
Get alerted when CVE-2026-53179 or the next vulnerability affects your stack