What’s Vulnerable › Vulnerabilities
CVE-2026-53205: accel/ivpu: Add bounds checks for firmware log indices
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-10-19
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: accel/ivpu: Add bounds checks for firmware log indices Add validation that read and write indices in the firmware log buffer are within valid bounds (< data_size) before using them. If out-of-bounds indices are encountered (from firmware), clamp them to safe values instead of proceeding with invalid offsets. This prevents potential out-of-bounds buffer access when firmware supplies invalid log indices.
Affected products
- Linux kernel: from 6.12.30 before 6.12.94; from 6.13 before 6.18.36; from 6.19 before 7.0.13; 7.1-rc1, 7.1-rc2, 7.1-rc3, 7.1-rc4, 7.1-rc5, 7.1-rc6 — fixed in 6.12.94, 6.18.36, 7.0.13
How to fix
Upgrade to a fixed version: Linux kernel 6.12.94, 6.18.36, 7.0.13. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/535da9ad8420c3b686a642403d4147ff220255fd
- https://git.kernel.org/stable/c/5961c703414048f46818be8bbb11075a9a63fb4e
- https://git.kernel.org/stable/c/8ec70c0dbdf04392a26e03e38798a373934177be
- https://git.kernel.org/stable/c/dd1311bcf0e62f0c515115f46a3813370f4a4bb1
Get alerted when CVE-2026-53205 or the next vulnerability affects your stack