What’s Vulnerable › Vulnerabilities
CVE-2026-53224: sctp: validate embedded INIT chunk and address list lengths in cookie
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-10-30
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: sctp: validate embedded INIT chunk and address list lengths in cookie sctp_unpack_cookie() only checked that the embedded INIT chunk length did not exceed the remaining cookie payload, but did not ensure that the INIT chunk is large enough to contain a complete INIT header. A malformed COOKIE_ECHO can therefore carry a truncated INIT chunk whose length field is smaller than sizeof(struct sctp_init_chunk). Later, sctp_process_init() accesses INIT parameters unconditionally, which may lead to out-of-bounds reads. In addition, raw_addr_list_len is not fully validated against the remaining cookie payload. When cookie authentication is disabled, an attacker can supply an oversized raw_addr_list_len and cause sctp_raw_to_bind_addrs() to read beyond the end of the cookie. The address parser also lacks sufficient bounds checks for parameter headers and lengths, allowing malformed address parameters to trigger out-of-bounds reads. Fix this by: - requiring the embedded INIT chunk length to be at least sizeof(struct sctp_init_chunk); - validating that the INIT chunk and raw address list together fit within the cookie payload; - verifying sufficient data exists for each address parameter header and payload before parsing it. Note that sctp_verify_init() must be called after sctp_unpack_cookie() and before sctp_process_init() when cookie authentication is disabled. This will be addressed in a separate patch.
Affected products
- Linux kernel: from 2.6.12.1 before 6.18.36; from 6.19 before 7.0.13; 2.6.12-rc2, 2.6.12-rc3, 2.6.12-rc4, 2.6.12-rc5, 7.1-rc1, 7.1-rc2 (+5); 2.6.12 — fixed in 6.18.36, 7.0.13
- Linux: 2.6.12 — fixed in 7.1
How to fix
Upgrade to a fixed version: Linux kernel 6.18.36, 7.0.13; Linux 7.1. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/29ab56e7660b6f849c10c46e87e085649df751eb
- https://git.kernel.org/stable/c/512a9bb77c04ac9927648ea58af617e472be96e6
- https://git.kernel.org/stable/c/6f4c80a2a7e6d06753b89a578b710a2499a5e62b
- https://git.kernel.org/stable/c/7560afb8cddafd829e709d7ea09230e45a825557
- https://git.kernel.org/stable/c/b1ca7dcfb335caa2c73d2d1bb5710e6dea2c11e0
- https://git.kernel.org/stable/c/dd75066882ecc4ec8df3f5384b4b9fa9579be8f0
Get alerted when CVE-2026-53224 or the next vulnerability affects your stack