What’s Vulnerable › Vulnerabilities
CVE-2026-53235: net: add pskb_may_pull() to skb_gro_receive_list()
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-07-08
Description
In the Linux kernel, the following vulnerability has been resolved: net: add pskb_may_pull() to skb_gro_receive_list() skb_gro_receive_list() calls skb_pull(skb, skb_gro_offset(skb)) without first ensuring the data is in the linear area via pskb_may_pull(). When the skb arrives via napi_gro_frags(), skb_headlen can be 0 (all data in page fragments) while skb_gro_offset is non-zero (after IP+TCP header parsing). The skb_pull() then decrements skb->len by skb_gro_offset but skb->data_len stays unchanged, hitting BUG_ON(skb->len < skb->data_len) in __skb_pull(). The UDP fraglist GRO path already contains this guard at udp_offload.c:749. Adding it to skb_gro_receive_list() itself provides centralized protection for all callers (TCP, UDP, and any future protocols), and ensures the precondition of skb_pull() is satisfied before it is called. On pskb_may_pull() failure, set NAPI_GRO_CB(skb)->flush = 1 so the skb is not held as a new GRO head and is instead delivered through the normal receive path, matching the UDP handling.
Affected products
- Linux kernel: from 6.10 before 6.12.94; from 6.13 before 6.18.36; from 6.19 before 7.0.13; 7.1-rc1, 7.1-rc2, 7.1-rc3, 7.1-rc4, 7.1-rc5, 7.1-rc6 (+1) — fixed in 6.12.94, 6.18.36, 7.0.13
How to fix
Upgrade to a fixed version: Linux kernel 6.12.94, 6.18.36, 7.0.13. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0cde3a004119db637b401c54e77536e4145fc0b4
- https://git.kernel.org/stable/c/848571dcbbbea7ba44dd4f7ebe1fbb274afe08ac
- https://git.kernel.org/stable/c/9e636c995b7beeb74ea882968248752821c244c4
- https://git.kernel.org/stable/c/f2bb3434544454099a5b6dec213567267b05d79d
Get alerted when CVE-2026-53235 or the next vulnerability affects your stack