What’s Vulnerable › Vulnerabilities
CVE-2026-53317: wifi: mt76: mt7921: Place upper limit on station AID
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-26 · updated 2026-10-30
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: mt76: mt7921: Place upper limit on station AID Any station configured with an AID over 20 causes a firmware crash. This situation occurred in our testing using an AP interface on 7922 hardware, with a modified hostapd, sourced from Mediatek's OpenWRT feeds. In stock hostapd, station AIDs begin counting at 1, and this configuration is prevented with an upper limit on associated stations. However, the modified hostapd began allocation at 65, which caused the firmware to crash. This fix does not allow these AIDs to work, but will prevent the firmware crash. This crash was only seen on IFTYPE_AP interfaces, and the fix does not appear to have an effect on IFTYPE_STATION behavior.
Affected products
- Linux kernel: from 5.12 before 6.12.91; from 6.13 before 6.18.33; from 6.19 before 7.0.10 — fixed in 6.12.91, 6.18.33, 7.0.10
- Linux: 5.12 — fixed in 7.1
How to fix
Upgrade to a fixed version: Linux kernel 6.12.91, 6.18.33, 7.0.10; Linux 7.1. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1a4b802afe15c5b33b2dcb37a594aba2fa215d52
- https://git.kernel.org/stable/c/35835ff71e6e618155578b8e3905597edd5f601c
- https://git.kernel.org/stable/c/4d0bf21e3e20619d51d06c0c36207aabab8b712c
- https://git.kernel.org/stable/c/6dbe70f9ef14d8ac1c24bf19fd9510978a3ab952
- https://git.kernel.org/stable/c/8f2ce0910b25173049910ec9a49304150534afd4
- https://git.kernel.org/stable/c/9d63dd026644fa612a1fd348d5d3ab5d73df7fb8
Get alerted when CVE-2026-53317 or the next vulnerability affects your stack