What’s Vulnerable › Vulnerabilities
CVE-2026-53346: rust: arm64: set uwtable llvm module flag for CONFIG_UNWIND_TABLES
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-01 · updated 2026-07-22
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: rust: arm64: set uwtable llvm module flag for CONFIG_UNWIND_TABLES Due to a rustc bug [1] the -Cforce-unwind-tables=y flag only emits the uwtable annotation for functions, but not for the module. This means that compiler-generated functions such as 'asan.module_ctor' do not receive the uwtable annotation. When CONFIG_UNWIND_PATCH_PAC_INTO_SCS is enabled, this leads to boot failures because the dwarf information emitted for the kasan constructors is wrong, which causes the SCS boot patching code to patch the constructor in an illegal manner. Specifically, the paciasp instruction is patched, but the autiasp instruction is not. This mismatch leads to a crash when the constructor is called during boot. ================================================================== BUG: KASAN: global-out-of-bounds in do_basic_setup+0x4c/0x90 Read of size 8 at addr ffffffe3cc7eb488 by task swapper/0/1 Specifically the faulting instruction is the (*fn)() to invoke the constructor in do_ctors() of the init/main.c file. Once the fix lands in rustc, this flag can be made conditional on the rustc version. Note that passing the flag on a rustc with the fix present has no effect. [ The fix [1] has landed for Rust 1.98.0 (expected release on 2026-08-20). Thus add a version check as discussed. - Miguel ] [ Adjusted link and comment. - Miguel ]
Affected products
- Linux kernel: from 6.12 before 6.12.94; from 6.13 before 6.18.36; from 6.19 before 7.0.13; 7.1-rc1, 7.1-rc2, 7.1-rc3, 7.1-rc4, 7.1-rc5, 7.1-rc6 — fixed in 6.12.94, 6.18.36, 7.0.13
How to fix
Upgrade to a fixed version: Linux kernel 6.12.94, 6.18.36, 7.0.13. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/7de13410f59e59b21d3c268a6e22d40f5d9d8a54
- https://git.kernel.org/stable/c/ac35b5580ace12e5d0a0b5e61e36d2c4e1ffa29c
- https://git.kernel.org/stable/c/bde772ee239720af216fb0b14753971059e132dc
- https://git.kernel.org/stable/c/d0f25a1755f2c15b1746379c8d9d7dfde85f58f5
Get alerted when CVE-2026-53346 or the next vulnerability affects your stack