What’s Vulnerable › Vulnerabilities
CVE-2026-53386: iio: adc: ti-ads1298: add bounds check to pga_settings index
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-08-17
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: iio: adc: ti-ads1298: add bounds check to pga_settings index ads1298_pga_settings has 7 elements but ADS1298_MASK_CH_PGA can yield values 0-7. If it yields a value >= 7, this causes an out-of-bounds array access. Add a bounds check and return -EINVAL if the index is out of range. Note that the remaining value b111 is reserved so should not be seen in a correctly functioning system.
Affected products
- Linux kernel: from 6.9 before 6.12.95; from 6.13 before 6.18.37; from 6.19 before 7.0.14; from 7.1 before 7.1.2 — fixed in 6.12.95, 6.18.37, 7.0.14, 7.1.2
How to fix
Upgrade to a fixed version: Linux kernel 6.12.95, 6.18.37, 7.0.14, 7.1.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/95e8a48d7a85d4226934020e57815a3316d3a14b
- https://git.kernel.org/stable/c/abd776ded3e256889610595290f6ca46cb6e91ab
- https://git.kernel.org/stable/c/abe0854e356b1bb814393ca884cb42b3eb12ce10
- https://git.kernel.org/stable/c/d08d82d83ed45fd8c001a9df66ad7ebb86c9d6c6
- https://git.kernel.org/stable/c/d5793975fc3b1780ba576812158ef22e3104e60e
Get alerted when CVE-2026-53386 or the next vulnerability affects your stack