What’s Vulnerable › Vulnerabilities
CVE-2026-53427: Cross-site scripting in MDEx via unescaped highlight_lines_class code-fence attribute
- Severity: low (CVSS 2.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-29 · updated 2026-10-25
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in leandrocp MDEx allows stored or reflected cross-site scripting via attacker-controlled Markdown. When syntax highlighting and full info-string forwarding (render: [full_info_string: true]) are enabled, the Lumis adapter copies the value of a code fence's highlight_lines_class info-string attribute, unescaped, into the class attribute of every rendered line. comrak_nif::lumis_adapter::LumisAdapter::parse_custom_attributes in native/comrak_nif/src/lumis_adapter.rs shlex-parses the info string and stores each key=value pair verbatim, highlight_lines_config pulls highlight_lines_class into the per-line class value, and write_highlighted interpolates that value directly into the class attribute of the per-line <div>. A single-quoted shell token preserves an inner double quote through shlex parsing, so a value such as '"><script>alert(1)</script>' terminates the class attribute early and the markup that follows is emitted as live HTML. An attacker who can submit Markdown (through comments, posts, wiki pages, documentation, or any user-generated content) can inject arbitrary HTML and JavaScript that runs in the browser of every user who views the rendered output, enabling session theft, account takeover, and other client-side attacks. No authentication or special privileges are required. The vulnerable native code originally shipped inside mdex (in native/comrak_nif/src/lumis_adapter.rs) and was later extracted into the separate mdex_native package (native/mdex_native_nif/src/lumis_adapter.rs), where it remains unpatched. This issue affects mdex from 0.11.3 before 0.12.3, and mdex_native from 0.1.0 before 0.2.3.
Affected products
- leandrocp mdex: from 0.11.3 before 0.12.3 — fixed in 0.12.3
- leandrocp mdex_native: from 0.1.0 before 0.2.3 — fixed in 0.2.3
How to fix
Upgrade to a fixed version: leandrocp mdex 0.12.3; leandrocp mdex_native 0.2.3. Check the vendor advisory for mitigations.
References
- https://cna.erlef.org/cves/CVE-2026-53427.html
- https://github.com/leandrocp/mdex_native/commit/798a363b4339f6f7162ec8437c4c9f9b5ae6fbf3
- https://github.com/leandrocp/mdex_native/security/advisories/GHSA-v664-pmxr-mxxx
- https://osv.dev/vulnerability/EEF-CVE-2026-53427
Get alerted when CVE-2026-53427 or the next vulnerability affects your stack