What’s Vulnerable › Vulnerabilities

CVE-2026-53435

Description

In Jenkins 2.567 and earlier, LTS 2.555.2 and earlier, it is possible for attackers to have Jenkins deserialize arbitrary types defined in Jenkins core or plugins from an attacker-controlled `config.xml` submission in a way that allows them to handle HTTP requests afterwards. This can be used to impersonate any user and send HTTP requests on their behalf, up to and including use of the Script Console to run arbitrary code, or to read arbitrary files from the Jenkins controller.

Affected products

How to fix

Upgrade to a fixed version: Jenkins 2.555.3, 2.568. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-53435 or the next vulnerability affects your stack