What’s Vulnerable › Vulnerabilities
CVE-2026-53465: ImageMagick: Heap Buffer Over-Write in SF3 encoder when writing multi-frame image
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-10 · updated 2026-07-23
- Weakness: CWE-122
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to version 7.1.2-25, a crafted multi-frame can result in a heap buffer over-write when encoding it with the SF3 encoder. This issue has been patched in version 7.1.2-25.
Affected products
- ImageMagick: before 7.1.2-25 — fixed in 7.1.2-25
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-25. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-53465 or the next vulnerability affects your stack