What’s Vulnerable › Vulnerabilities

CVE-2026-53527: LeafWiki Vulnerable to Privilege Escalation via User Self-Service Update

Description

LeafWiki is a self-hosted wiki. Versions 0.1.0 through 0.10.0 have a privilege escalation vulnerability in the user update API. An authenticated user could update their own account role and escalate privileges from a regular user, such as `viewer`, to `admin`. Exploitation requires a valid authenticated LeafWiki user account. Instances without public registration and with only trusted users are at lower practical risk. Users should update to version 0.10.1 or greater. Until a patch is available, operators should restrict account creation and ensure that only trusted users have accounts on affected LeafWiki instances. If possible, access to the user update API should be restricted to trusted users or administrators only.

Affected products

References

Get alerted when CVE-2026-53527 or the next vulnerability affects your stack