What’s Vulnerable › Vulnerabilities
CVE-2026-53655: node-tar applies PAX size override to intermediary GNU long-name/long-link headers, causing tar parser interpretation differential (file smuggling)
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-22 · updated 2026-10-25
- Weakness: CWE-436
Description
node-tar is a full-featured Tar for Node.js. Prior to 7.5.16, tar (node-tar) applies a PAX extended header's size= record (and other PAX overrides) to the next header entry of any type, including intermediary metadata headers such as a GNU long-name (L) or long-link (K) entry. Per POSIX pax, a PAX extended header (x) describes the next file entry, not the intermediary extension headers that may sit between the x header and the file it annotates. Because node-tar lets the PAX size override the byte length of an intervening L/K/x header, an attacker can desynchronize node-tar's stream cursor relative to every other mainstream tar implementation (GNU tar, libarchive/bsdtar, Python tarfile, and the now-fixed tar-rs / astral-tokio-tar). The result is a tar parser interpretation differential (CWE-436): a single crafted archive yields a different set of members under node-tar than under the reference tar tools. An attacker can use this to hide a member from one parser while it is visible to another, which defeats security tooling whose scanner and extractor disagree on archive contents (e.g. a malware/secret scanner that lists entries with one library while a downstream step extracts with another) This vulnerability is fixed in 7.5.16.
Affected products
- isaacs node-tar: before 7.5.16 — fixed in 7.5.16
- Npm Tar: before 7.5.16 — fixed in 7.5.16
How to fix
Upgrade to a fixed version: isaacs node-tar 7.5.16; Npm Tar 7.5.16. Check the vendor advisory for mitigations.
References
- https://github.com/isaacs/node-tar/security/advisories/GHSA-vmf3-w455-68vh
- https://github.com/isaacs/node-tar/security/advisories/GHSA-vmf3-w455-68vh
Get alerted when CVE-2026-53655 or the next vulnerability affects your stack