What’s Vulnerable › Vulnerabilities
CVE-2026-53694: Potential local privileges escalation through argument injection in the nxchmod.sh script
- Severity: high (CVSS 7.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-10 · updated 2026-07-07
- Weakness: CWE-88
Description
Improper Neutralization of Argument Delimiters in a Command ('Argument Injection') vulnerability in Nomachine allows Argument Injection.This issue affects Nomachine: before 9.5.7, before 8.23.2.
Affected products
- NoMachine: from 7.0.0 before 9.5.7; from 7.0.0 before 8.23.2 — fixed in 8.23.2, 9.5.7
How to fix
Upgrade to a fixed version: NoMachine 8.23.2, 9.5.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-53694 or the next vulnerability affects your stack