What’s Vulnerable › Vulnerabilities
CVE-2026-53720: pymonocypher: Potential heap buffer overflow on nb_blocks in argon2i_32 when provided buffer is too small
- Severity: medium (CVSS 5.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-03 · updated 2026-09-09
- Weakness: CWE-122
Description
pymonocypher uses cython to wrap the Monocypher C library. Prior to version 4.0.2.8, the argon2i_32 implementation does not check the nb_blocks size. If the caller does not provide a sufficiently large buffer based on the API contract, then argon2i_32 will write past the end of the buffer and possibly corrupt the heap. This issue has been patched in version 4.0.2.8.
Affected products
- jetperch pymonocypher: before 4.0.2.8
References
- https://github.com/jetperch/pymonocypher/commit/90ff5b13b13b5673c372e188f482d8c172e6ab86
- https://github.com/jetperch/pymonocypher/releases/tag/v4.0.2.8
- https://github.com/jetperch/pymonocypher/security/advisories/GHSA-8f95-v3jq-cj86
Get alerted when CVE-2026-53720 or the next vulnerability affects your stack