What’s Vulnerable › Vulnerabilities
CVE-2026-53776: Perry < 0.5.1166 JWT Expiration Bypass via verify_decode
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-16 · updated 2026-10-25
- Weakness: CWE-613
Description
Perry before 0.5.1166 contains a JWT validation vulnerability that allows remote attackers to bypass token expiration by exploiting the unconditional setting of validate_exp = false in the verify_decode helper within the stdlib JWT verification path. Attackers in possession of a previously issued bearer token can present expired tokens to any jwt.verify() call and retain authenticated access indefinitely, bypassing force-expired sessions such as user logout or administrative revocation.
Affected products
- PerryTS perry: before 0.5.1166 — fixed in 0.5.1166
How to fix
Upgrade to a fixed version: PerryTS perry 0.5.1166. Check the vendor advisory for mitigations.
References
- https://github.com/PerryTS/perry/releases/v0.5.1166
- https://github.com/PerryTS/perry/security/advisories/GHSA-5324-c68v-8w62
- https://www.vulncheck.com/advisories/perry-jwt-expiration-bypass-via-verify-decode
Get alerted when CVE-2026-53776 or the next vulnerability affects your stack