What’s Vulnerable › Vulnerabilities
CVE-2026-53809: OpenClaw < 2026.4.25 - Provider Alias Confusion in Embedded Runner Policy
- Severity: low (CVSS 3.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-11 · updated 2026-06-17
- Weakness: CWE-863
Description
OpenClaw before 2026.4.25 contains a policy bypass vulnerability in embedded runner policy that allows requests using provider aliases to compare against aliases instead of canonical provider identities. Attackers can exploit this confusion to select bundled tool access outside intended provider policy restrictions when the affected feature is enabled.
Affected products
- OpenClaw: before 2026.4.25 — fixed in 2026.4.25
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.25. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-p39j-x9h5-q66m
- https://www.vulncheck.com/advisories/openclaw-provider-alias-confusion-in-embedded-runner-policy
Get alerted when CVE-2026-53809 or the next vulnerability affects your stack