What’s Vulnerable › Vulnerabilities
CVE-2026-53817: OpenClaw < 2026.5.22 - Control UI Locality Spoofing in Device Pairing
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-11 · updated 2026-06-17
- Weakness: CWE-290
Description
OpenClaw before 2026.5.22 contains a locality validation vulnerability in Control UI pairing that allows attackers with network access to spoof locality information and obtain durable admin-capable device tokens. Attackers can exploit insufficient locality-derived trust validation to convert temporary shared access into persistent administrative credentials that survive token rotation.
Affected products
- OpenClaw: before 2026.5.22 — fixed in 2026.5.22
How to fix
Upgrade to a fixed version: OpenClaw 2026.5.22. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-chr9-m4q2-76hw
- https://www.vulncheck.com/advisories/openclaw-control-ui-locality-spoofing-in-device-pairing
Get alerted when CVE-2026-53817 or the next vulnerability affects your stack