What’s Vulnerable › Vulnerabilities
CVE-2026-53821: OpenClaw < 2026.5.18 - Scope Elevation in trusted-proxy Control UI WebSocket
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-12 · updated 2026-07-23
- Weakness: CWE-862
Description
OpenClaw before 2026.5.18 accepts WebSocket client-declared operator scopes before binding to server-approved pairing or trusted-proxy authorization baseline. Unpaired or restricted trusted-proxy Control UI clients can obtain cached operator.admin authority on live WebSocket connections to execute admin-gated Gateway RPCs.
Affected products
- OpenClaw: before 2026.5.18 — fixed in 2026.5.18
How to fix
Upgrade to a fixed version: OpenClaw 2026.5.18. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-qjpc-qf9m-xwmr
- https://www.vulncheck.com/advisories/openclaw-scope-elevation-in-trusted-proxy-control-ui-websocket
Get alerted when CVE-2026-53821 or the next vulnerability affects your stack