What’s Vulnerable › Vulnerabilities
CVE-2026-53834: OpenClaw < 2026.4.27 - Authorization Bypass in QQBot Pre-dispatch Slash Commands
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-12 · updated 2026-07-20
- Weakness: CWE-863
Description
OpenClaw before 2026.4.27 contains an authorization bypass vulnerability in QQBot pre-dispatch slash commands that allows authenticated senders to skip allowFrom policy checks. Attackers can invoke slash commands before configured access control policies are applied, potentially triggering command handling from blocked senders depending on operator configuration.
Affected products
- OpenClaw: before 2026.4.27 — fixed in 2026.4.27
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.27. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-77pv-3w4q-vrj5
- https://www.vulncheck.com/advisories/openclaw-authorization-bypass-in-qqbot-pre-dispatch-slash-commands
Get alerted when CVE-2026-53834 or the next vulnerability affects your stack